[CentOS] KVM guests failed to start after 6.2 upgrade

Thu Dec 22 17:10:42 UTC 2011
Akemi Yagi <amyagi at gmail.com>

On Thu, Dec 22, 2011 at 8:26 AM, Paul Heinlein <heinlein at madboa.com> wrote:

> What worked for me was running "virsh edit" against each (now
> shutdown) domain, removing all the <address> tags in the <devices>
> section, e.g.,
>   <devices>
>     <disk>
>       <address type='pci' .../>
>     </disk>
>     <interface>
>       <address type='pci' .../>
>     </interface>
>     <memballoon>
>       <address type='pci' .../>
>     </memballoon>
>   </devices>
> All the VMs started without any issue after that, though I'll admit
> have haven't tried re-starting them since the fix.

I have those lines in my .xml files and there is no issue with running
kvm guests on a 6.2 host.

What I suspect happened is that running 'virsh edit' did some
adjustments to the xml files. I know that occurred in the past
(perhaps when going from el5 to el6 ??). So, when updating/upgrading
the host OS, it is worth running it.