[CentOS] problem starting X11 on centos 6

Jerry Geis geisj at pagestation.com
Fri Jul 22 14:00:12 UTC 2011

Jerry Geis wrote:
> Hi All,
> I had an issue. Manually installing Centos 6 everything worked X11 
> came up with nvidia binary drivers. Cool.
> However, I am working on a kickstart install for Centos 6 and that was 
> not working. When I started X it
> would hang. no mouse no keyboard. however , remote ssh was available 
> and worked.
> Thinking I had some serious bug in nvidia binary was my thought - but 
> I kept looking.
> I saw this error:
> (EE) config/hal: couldn't initialise context: unknown error (null)
> in the X log file.
> I continued to look and sure enough hald was installed but not running.
> I did service  haldaemon stop and it said FAILED as expected, then 
> service haldaemon start
> and it started up. Curious....
> chkconfig --list | grep hal reports
> haldaemon       0:off   1:off   2:off   3:off   4:off   5:off   6:off
> So thats the reason of course, it was not set to start. Question is 
> why????
> certainly I can put in my kickstart post script to change chkconfig
> but why is it not set to start????
> Thanks for any insite.
> Jerry
After further investigating... I found the issue. I was in fact turning 
off haldaemon.
Some obscure install script I forgot about.
This must have been ok in centos 5 and X as I just checked my machines 
and in fact it is off.
Not sure why I turned it off way back...



More information about the CentOS mailing list