[CentOS] Booting CentOS 6 in VirtualBox on Ubuntu

Marko Vojinovic vvmarko at gmail.com
Wed Jul 27 14:57:27 UTC 2011

On Wednesday 27 July 2011 05:26:15 Cliff Pratt wrote:
> I trying to try out CentOS 6 in an Oracle VirtualBox running on
> Ubuntu. Has anyone been able to get this configuration working?

I did it under Fedora rather than Ubuntu, but in general yes, it works.
> When I try to boot the "Live" ISO it starts to do the countdown but
> when it reaches zero it gets stuck - nothing else happens. No error
> messages and since the install never really gets going, no logs.

I've had this problem with Fedora 15 Live CD --- when trying to install it 
into the VirtualBox VM running on the Fedora 14 host.

It would do the countdown, and just hang. Then I tried the DVD installation, 
and instead of just hanging, it politely told me that I am using the wrong 
kernel for this architecture.

That was a clue what to look for --- I tried to install the 64bit version into 
VirtualBox The host was also 64bit, so I thought it would Just Work. But it 
doesn't. After downloading the 32bit version of the LiveCD, it worked 

Then I RTFM:


which explained a lot of things for me. ;-)

HTH, :-)

More information about the CentOS mailing list