[CentOS] How to remove a Trash folder from a mounted ntfs partition

Sat Oct 22 00:50:39 UTC 2011
David <bouncingcats at gmail.com>

On 22 October 2011 02:24, James B. Byrne <byrnejb at harte-lyne.ca> wrote:
> CentOS-5.7 using fuse-ntfs-3g
> I have a HDD from a laptop that is being returned for
> repair replacement.  I wish to remove certain files before
> sending the laptop back with the HDD.
> I have mouunted the HDD on my desktop as an ntfs
> filesystem using an external SATA / USB adapter.  As root
> I then used the gnome desktop to move the desired files to
> trash.  Now I wish to delete the contents of the trash
> folder and the folder itself. This I cannot do.  I have
> tried deleting using rm -rf ./.Trash-root but the command
> simply has no effect.  It raises no error and it does not
> remove the Directory or its contents.
> For convenience I renamed the directory to DeleteME using
> move, which worked. As expected through, all attempts to
> remove DeleteME still fail silently.  The permission bits
> are set thus:
> dr-xr-xr-x 1 root root 488 Oct 21 10:54 DeleteMe
> I have tried chmod -R 777 DeleteMe but this has no effect
> on the permissions.
> How do I get rid of this thing?

1) Try in runlevel 3 ie without gnome/X running.
2) If selinux is running on the desktop, set it to permissive.
3) What does the output of mount command say about the ntfs partition?
4) What options did you specify when mounting the ntfs partition?
5) Have you considered the mount options for ntfs as documented in man mount?