[CentOS] How to remove a Trash folder from a mounted ntfs partition

Tue Oct 25 00:07:47 UTC 2011
James B. Byrne <byrnejb at harte-lyne.ca>

On Fri, October 21, 2011 20:50, David wrote:
> On 22 October 2011 02:24, James B. Byrne
> <byrnejb at harte-lyne.ca> wrote:
>> CentOS-5.7 using fuse-ntfs-3g
>> I have a HDD from a laptop that is being returned for
>> repair replacement.  I wish to remove certain files
>> before sending the laptop back with the HDD.
>> I have mouunted the HDD on my desktop as an ntfs
>> filesystem using an external SATA / USB adapter.  As
>> root I then used the gnome desktop to move the desired
>> files to trash.  Now I wish to delete the contents
>> of the trash folder and the folder itself. This I
>> cannot do.  I have tried deleting using rm -rf
>> ./.Trash-root but the command simply has no effect.
>> It raises no error and it does not remove the
>> Directory or its contents.
>> For convenience I renamed the directory to DeleteME
>> using move, which worked. As expected through, all
>> attempts to remove DeleteME still fail silently.  
>> The permission bits
>> are set thus:
>> dr-xr-xr-x 1 root root 488 Oct 21 10:54 DeleteMe
>> I have tried chmod -R 777 DeleteMe but this has no
>> effect on the permissions.
>> How do I get rid of this thing?
> Ideas:
> 1) Try in runlevel 3 ie without gnome/X running.
> 2) If selinux is running on the desktop, set it to
> permissive.
> 3) What does the output of mount command say about the
> ntfs partition?
> 4) What options did you specify when mounting the ntfs
> partition?
> 5) Have you considered the mount options for ntfs as
> documented in man mount?

The situation is resolved.  The laptop was dead and
unrevivable.  Our internal network policies forbide
attaching any recorded media that have been outside the
gateway.  (The laptop was the president's, which is the
only reason it got on-site to begin with, sigh.)

In the end I had to mount the drive in an external usb
housing and plug it into a windows box segregated from the
network.  I discovered in the process that the read only
bit is ignored by windows when it is set for a directory. 
I also discovered that using deltree from the windows cli
leaves ghost folders where the files have been removed but
sub-directories have not.

Eventually I got everything off, the space marked as
clean, and then wiped repetitively over the weekend.

***          E-Mail is NOT a SECURE channel          ***
James B. Byrne                mailto:ByrneJB at Harte-Lyne.ca
Harte & Lyne Limited          http://www.harte-lyne.ca
9 Brockley Drive              vox: +1 905 561 1241
Hamilton, Ontario             fax: +1 905 561 0757
Canada  L8E 3C3