[CentOS] Kernel Panic - not syncing: Attempted to kill Init!

Mon Aug 20 17:23:54 UTC 2012
m.roth at 5-cent.us <m.roth at 5-cent.us>

Joseph Koenig wrote:
>>> Just installed CentOS 6.3 from a minimal install disc. All was well, so
>>> I ran a yum update, as well as installed some additional packages
>>> (mysql, httpd, libjpeg, libpng, and more that I don't remember off the
>>> top of my head). Went to reboot the machine and now it won't book up.
>>> As it starts to boot, says:
>>> Kernel panic - not syncing: Attempted to kill init!
>>> Pid: 1, comm: init Not tainted 2.6.32-279.5.1.el6.x86_64 #1
>>> Call Trace:
>>> [<ffffffff814fd24a>] ? panic+0xa0/0x168
>> <snip>
>> My first reaction is when the menu, or the "about to boot kernel..."
>> line comes up, edit that, then add rdshell to the end of your kernel line,
>> and let it boot. If it gets to the rdshell, you might check to see if
>> there's an agreement between the root (hdx,x) line in grub.conf and
what the
>> system leads grub to think is the first h/d.

> Thanks for the suggestion - just tried and doesn't get to rdshell. The
> panic happens within a few seconds (if not less) from when I edit the
> kernel line and hit enter to start booting.

>> Also, here's what I'm assuming: a) the PERC controller is actually
>> presenting the drives to the system, and b) that grub was in fact
>> installed.

> Yes, grub was installed, and it would seem PERC controller is presenting
> drives to the system - at least it was. Before I ran a yum update after
> installing the system, I could boot it and log in just fine.
> Worth reinstalling from the minimal install disc again just to make sure
> that still works? Would that rule out something having gone awry with my
> RAID card or disk?

You *might* want to try installing the minimal server version. Minimal
means a lot less....