[CentOS] Kernel Panic - not syncing: Attempted to kill Init!

Mon Aug 20 17:41:18 UTC 2012
m.roth at 5-cent.us <m.roth at 5-cent.us>

Joseph Koenig wrote:
>>> Yes, grub was installed, and it would seem PERC controller is
>>> presenting
>>> drives to the system - at least it was. Before I ran a yum update after
>>> installing the system, I could boot it and log in just fine.
>>> Worth reinstalling from the minimal install disc again just to make
>>> sure
>>> that still works? Would that rule out something having gone awry with
>>> my
>>> RAID card or disk?
>> You *might* want to try installing the minimal server version. Minimal
>> means a lot less....
> Installed from minimal the first time around, which is why I thought
> doing that again may be helpful. You think I'd be best to get the full
> install and run that though?
Well, I think there's a minimal server, rather than the full server
install. Of course, I could be confusing that with our pxeboot setup....

Odd thought: have you tried a) looking at the drives in the PERC firmware,
or b) booting to linux rescue, and examining the filesystems?