[CentOS] network intermitent, not sure if virtualization issue

Mon Feb 6 06:46:01 UTC 2012
Bob Hoffman <bob at bobhoffman.com>

centos 6 host, centos 6 virtual machine.
Network connection from outside server disappears in regards to the 
virtual server.


Tested the heck out of it.

Further testing shows the network unreachable, even if network restarted 
in host.
A simple ping from the virtual machine going out allows full traffic 
both ways.
Intermittent time out, it may last 5 minutes, it may last an hour, but 
it will disappear.

I found a small config sample on an old website in the middle of nowhere.
It had an addition to the /etc/sysconfig/network file of the host.
it added "GATEWAY=br0"

I did this and restarted the network service and I believe without me 
doing anything, this appeared in
the virtual machine message logs, something that had never appeared before.

kernel: Bridge firewalling registered

so hoping that is it...not sure if I would need to do that on the 
virtual machine or not.
I have been days at this. Literally rewrote every single ifcfg and conf 
file I could find.
Tried hundreds of permutations. Nothing has worked.

If this does not work I am willing to pay someone to end my week long 
battle with the virtual machine network being unreachable no matter what 
I do.
But only if you actually know this stuff and actually have experience 
with the virtual machine bridging..and hopefully have seen this type of 

<banging head on wall> <repeat> <rinse> <repeat>