[CentOS] my notes on bond, bridge, network, kvm, host and virtual so far

Tue Feb 7 06:51:00 UTC 2012
Bob Hoffman <bob at bobhoffman.com>

Hi all, thanks for taking an interest.
been populating the page with all the data I could.

as someone who sent me a mail noticed that there was still some 
networkmanager stuff in the
log messages. I have disabled it before..and did so again, fresh reboot 
and there it was.

I am using startx to enter into a mini desktop on the unit (via impi) 
and that seemed to
restart networkmanager for some odd reason.

I cleaned it up some more and am waiting to see if it fails. (it can 
take up to one hour to fail, so
I try to only do 3 or 4 things at once and wait til it goes...sigh.)


I tried with and without hwaddress in the files and found no difference. 
I took them out again for this try
and using mode 6 which is set to rewrite. A number of the modes required 
switch support according to
docs and I tried testing them out but using hwaddress to get around it 
(well, worth a shot).

the worst part is the depth of time it takes. Sometimes almost an hour 
goes by and I say 'eureka!!'
and continue working on the server, proud of myself...then 'bam' no 

screwing around on the vm got me to screw up the network on there 
now..seems eth0 does not exist and it wants eth2...lol