[CentOS] vmware fusion display auto-size problem

Peter Eckel lists at eckel-edv.de
Wed Jan 4 13:03:48 UTC 2012

Hi Monty, 

> I am running vmware fusion 4.1.1 on a OSX host.

Same here.

> Centos6.2 is a guest. 

Same here.

> The box is a macbook laptop running leopard.

OK, there's a difference - I have a Mac Pro running Snow Leopard. But that shouldn't make a difference.

> Before upgrading to 6.2, the display auto-resize (or auto-fill) was 
> working fine. After 6.2, it has stopped working.

Works here. 

> Centos is fully updated to 6.2.

Same here. 

> I have tried to install the vmware  drivers from the repository (via yum),
> and yum reports I have the latest. Vmware reports I have the latest
> version of app and linux tools.

My current versions are: 

  xorg-x11-drv-vmware.x86_64         11.0.3-1.el6 
  xorg-x11-drv-vmmouse.x86_64        12.7.0-1.el6
  xorg-x11-drv-vmware.x86_64         11.0.3-1.el6

VMware Tools version is: 


This is the version that was downloaded by Fusion after the upgrade to 4.1.1. 

> I have uninstalled and re-installed vmware tools to no avail.  During 
> the vmware tools install it returns a statement that it does not have 
> drivers for x:

I get the statement that it does not install X drivers since there are drivers installed by the distribution, but resizing works fine, so the drivers should be up-to-date.
  Detected X server version 1.10.4
  Distribution provided drivers for Xorg X server are used.
  Skipping X configuration because X drivers are not included.

> Anybody else come across this?  Google and vmware sites either do not 
> have any info, or I am asking the wrong question.
> This being my first foray into vmware, is it advisable not to run 
> updates until needed?  What is best practice in this config?

I usually install all updates provided by CentOS (the VMs I run on Fusion are mostly test systems). From time to time, there are kernel updates that are not compatible with VMware Tools, but usually a reconfiguration (with installed gcc/required libs/kernel headers) fixes that. It's also possible to enable 'VMware automatic kernel modules', an experimental feature of VMware Tools, that should automate that process. You can enable it by re-running vwmware-install.pl or running /usr/bin/vmware-config-tools.pl


More information about the CentOS mailing list