[CentOS] EPEL not working ... is it just me?

Denniston, Todd A CIV NAVSURFWARCENDIV Crane todd.denniston at navy.mil
Wed Jan 11 15:28:25 UTC 2012

> -----Original Message-----
> From: centos-bounces at centos.org [mailto:centos-bounces at centos.org] On
> Behalf Of Alan McKay
> Sent: Wednesday, January 11, 2012 9:36
> To: CentOS mailing list
> Subject: [CentOS] EPEL not working ... is it just me?
> This is very strange - has been happening the last few days.   I just
> upgraded this system from 5.3 to 5.7 on Monday and the problem started
> some
> time after that (but not immediately because I know I used yum Monday
> evening after the upgrade)
> I get the following error from yum, but it goes away if I --
> disablerepo=epel
> The funny thing is that the listed xml file I can easily wget from
> system.

You mean in the terminal on solexa-db you just issued the yum install
in, you can issue as the next command
wget http://fedora.mirror.nexicom.net/epel/5/x86_64/repodata/repomd.xml

and it gets the xml file?

> Also having the issue with other 5.7 systems that were upgraded from
> 5.3
> several weeks ago and had been working fine since.
<SNIP yum and rpm cleans> 
> [root at solexa-db varlog]# yum -y install hddtemp
> Loaded plugins: downloadonly, rhnplugin, security
> http://fedora.mirror.nexicom.net/epel/5/x86_64/repodata/repomd.xml:
> [Errno
> 4] IOError: <urlopen error (111, 'Connection refused')>
> Trying other mirror.
> Error: Cannot retrieve repository metadata (repomd.xml) for
> epel. Please verify its path and try again

It seems a bit strange to me that there is only one mirror tried...
As a quick temporary fix/test I would comment mirrorlist and uncomment
baseurl in epel.repo and see if the yum command worked.

BTW it seems solexa-db may be a RH machine instead of a CentOS machine.
see the rhnplugin get loaded? Could that be a difference between the
working and non working machines (granted I have not seen any problems
with RH machines and epel)?

I think it might be good to take this question over to epel-devel (AFAIK
the appropriate list) and see if they can help figure out why you are
having trouble with THEIR infrastructure.

More information about the CentOS mailing list