[CentOS] doing a new install on top of existing software raid-1

Les Mikesell lesmikesell at gmail.com
Sun Jan 22 01:52:30 UTC 2012

On Sat, Jan 21, 2012 at 5:29 PM, Gordon Messmer <yinyang at eburg.com> wrote:
> On 01/19/2012 01:53 PM, Les Mikesell wrote:
>> I tried to boot a 5.x system with several raid1 sets with a 6.0 live
>> dvd and not only did it not detect/match up the mirrors, it renamed
>> and broke them so they no longer worked on 5.x.  I think there are
>> major differences in the way the kernel handles things.   I probably
>> won't try to access existing arrays again unless someone else reports
>> success, and even then I'll probably pull one of the drives of each
>> set until I'm convinced it is safe to sync them back.
> As far as I know, it's not a kernel version thing...  If you attach
> disks with partitions using MD 0.95 metadata (which Anaconda will
> create) to another system, or boot live media in a system with such
> disks, the kernel may modify the minor number in the MD metadata.  In
> order to fix that, you'll need to stop the volumes, then construct them
> manually using the device name that you want and the
> --update=super-minor argument.

I have moved raid sets to other machines (of similar distribution
revs) and never had a problem before.  In fact I have fairly regularly
split raid1 volumes to different machines and re-synced with new
mirrors and never had any surprises before.  The real issue with this
box was that the disks are all swappable and I had used raid with
autodetect specifically so I didn't have to track which disk was
where.   And after booting the live dvd, they became more or less
randomly named md devices, with each disk of the set becoming its own
md device instead of pairing.  Recovering was fairly painful.

   Les Mikesell
    lesmikesell at gmail.com

More information about the CentOS mailing list