[CentOS] GUI login issues over NFS

Michael Weiner hunter at userfriendly.net
Thu Jan 26 19:46:29 UTC 2012

On Thu, Jan 26, 2012 at 2:22 PM, Thomas Burns <tburns at hawaii.edu> wrote:

> Any relevant messages in /var/log/messages of the server? Is automount
> able to mount and it is "just" a permissions problem?
> I had a vaguely similar problem recently, trying to get OSX to access
> NIS/NFS, it needs different mount options in the automounter config.
> You say you tried with automount turned off, were you able to mount
> manually but not able to access? Same error message?
> What does nsswitch.conf look like?
> Generally my trouble shooting goes like this:
> 1) get NIS to work ('ypcat mymap' works)
> 2) mount NFS share manually with mount command and access as root
> 3) access NFS share as ordinary user
> 4) get automount to mount the share

Thanks for your response Dave! I have been unable to find anything
relevant in the server syslogs. But here is what i have tried:

1) ypcat mymap gives me back what i would expect, as does a ypcat -k
passwd | grep myusername
2) I can mount the share manually on the workstation (using -o
nfsvers=3,rw,hard,intr options) and it mounts and i can traverse it as
a root user
3) I can mount the share manually on the workstation and i can
traverse it as root and as a local user
4) i can then put the map in place, restart autofs, log in via a NIS
account and it maps correctly and i can traverse it properly in a
shell (i.e. ssh, etc)
5) i tried mounting manually, creating a $home directory for a new
user, giving that user a password and i can ssh in but not Gnome or
6) variations of the above.

And this *IS* working currently on a Sun X4540 system, and the
NON-HOME directories that get mapped upon login correctly map on the
HP X9320 via NIS authentication just not X.

Thanks for the help and logical thinking.

More information about the CentOS mailing list