[CentOS] GUI login issues over NFS

Thomas Burns tburns at hawaii.edu
Thu Jan 26 19:22:21 UTC 2012

On Thu, Jan 26, 2012 at 5:46 AM, Weiner, Michael <weinerm at ccf.org> wrote:
> Has anyone run into a similar problem?

Different  versions of NFS and automount over time and over platforms
requiring slightly different config tweaks - this problem is always
kicking my butt.

Any relevant messages in /var/log/messages of the server? Is automount
able to mount and it is "just" a permissions problem?

I had a vaguely similar problem recently, trying to get OSX to access
NIS/NFS, it needs different mount options in the automounter config.

You say you tried with automount turned off, were you able to mount
manually but not able to access? Same error message?

What does nsswitch.conf look like?

Generally my trouble shooting goes like this:
1) get NIS to work ('ypcat mymap' works)
2) mount NFS share manually with mount command and access as root
3) access NFS share as ordinary user
4) get automount to mount the share


More information about the CentOS mailing list