[CentOS] After a long break, one more try at bond/bridge nics - solved

Bob Hoffman bob at bobhoffman.com
Sat Jan 28 03:03:38 UTC 2012

well...still cleaning up files to find what is and is not needed in 
those eth, bond, and br files...

here goes..

eth files
nm_controlled no, master=bond0, slave=yes
no ipaddresses or any of that stuff...

bond file..
#1 thing....it must be name ifcfg-bond0, not just bond0
However, the eth files must reference solely as bond0 without the ifcfg.
the bond file, for the moment had the ip addresses and stuff, not sure 
if I need them there or not.
(probably do not need them, but it worked with them)
bonding options go in this file too.

in etc/modprobe.d/ you need to make a file called bonding.conf
add this line
alias bond0 bonding

the ifcfg-br0 file, MUST be named ifcfg-br0 (or whatever your bridge is 
name, br1, br2, etc)
should contain type=Bridge
VERY IMPORTANT YOU SPELL IT WITH A CAPITAL B, and lowercase the rest of 
the word bridge.
(that is what was needed...go figure)
add the ipaddresses, netmask, etc etc etc to this file

you want to add your dns servers, or for a quickie fix add
(these are googles free dns resolvers)

anyway, this is just a quickie solution, will be posting a vid of each 
step soon..

updated from 6.0 to the new version....big update...gotta wait...won't 
let me access the VMs
while updating...sounds scary...yikes

More information about the CentOS mailing list