[CentOS] One of my servers wont boot today

Kahlil Hodgson kahlil.hodgson at dealmax.com.au
Mon Jan 30 23:49:34 UTC 2012

On Mon, 2012-01-30 at 15:43 -0800, Jason T. Slack-Moehrle wrote:

> It says:
> /dev/VolGroup00/. The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock: e2fsck -b 8193 <device>
> So I tried e2fsck -b 8193 /dev/VolGroup00 
> and it seems I get the same error coming up over and over
> I tried:
> fsck -y b=8193 /dev/VolGroup00 as well
> Any thoughts?

You need to fsck each logical volume, not the whole volume group, e.g.

e2fsck -b 8193 /dev/VolGroup00/LogVol01

or whatever.  
Look under /dev/VolGroup00 to see what's there.

Kahlil (Kal) Hodgson                       GPG: C9A02289
Head of Technology                         (m) +61 (0) 4 2573 0382
DealMax Pty Ltd                            (w) +61 (0) 3 9008 5281

Suite 1005
401 Docklands Drive
Docklands VIC 3008 Australia

"All parts should go together without forcing.  You must remember that
the parts you are reassembling were disassembled by you.  Therefore,
if you can't get them together again, there must be a reason.  By all
means, do not use a hammer."  -- IBM maintenance manual, 1925

More information about the CentOS mailing list