[CentOS] Recent kernel update vs usb disk

Wed Mar 7 13:43:47 UTC 2012
wwp <subscript at free.fr>

Hello John,

On Wed, 7 Mar 2012 05:25:55 -0800 (PST) John Doe <jdmls at yahoo.com> wrote:

> From: wwp <subscript at free.fr>
> > When I plug the disk, this wakes it up and I see in /var/log/messages:
> > kernel: usb 2-4.2: USB disconnect, address 11
> > kernel: usb 2-2: new high speed USB device using ehci_hcd and address 13
> > kernel: usb 2-2: New USB device found, idVendor=1ca1, idProduct=18a9
> > kernel: usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
> > kernel: usb 2-2: Product: Usb Sata Bridge
> > kernel: usb 2-2: Manufacturer: SYMWAVE
> > kernel: usb 2-2: SerialNumber: 3559443452593133
> > kernel: usb 2-2: configuration #1 chosen from 1 choice
> > kernel: scsi11 : SCSI emulation for USB Mass Storage devices
> > but it's not getting mounted.
> Up to where did you cut the output...?
> Did you get the SCSI device at all?
> if not, is hald running and polling /dev/sd* (ps auxfw | grep hald)?

Thanks for your reply!

I shown the lines that appeared in system log since the moment I plug
the device, there's nothing after (and nothing before that matters, at
least WRT to the "plug" event itself).

No, the device is not even accessible using /dev/sdXX. Gparted and
other tools don't even see it. But my laptop's internal disk and other
externals USB (SATA or IDE) disks are accessible.

The issue seems focused on that particular external USB disk, and I
never get it as /dev/sdXX whatever I plug it directly to one of this
laptop's USB ports or to a USB multi-port.

The issue is not present with kernel 2.6.32-131.21.1.el6,
it's present with updates 2.6.32-220.4.1.el6 and 2.6.32-220.4.2.el6.

FYI it's a CentOS6 64bit installed on a DELL Latitude E6500.

I tried unplugging all USB storage devices, unloaded usb_storage
module, re-loaded it. Plugged in the disk and nothing better.

I tried with another laptop (DELL D810) with an up-to-date CentOS6
(32bit) installed on it: same behaviour, the disk is not accessible w/
latest kernel but is accessible w/ 2.6.32-131.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://lists.centos.org/pipermail/centos/attachments/20120307/470a5927/attachment-0004.sig>