[CentOS] Recent kernel update vs usb disk

Wed Mar 7 14:39:50 UTC 2012
John Doe <jdmls at yahoo.com>

From: wwp <subscript at free.fr>

> No, the device is not even accessible using /dev/sdXX. Gparted and
> other tools don't even see it. But my laptop's internal disk and other
> externals USB (SATA or IDE) disks are accessible.
> The issue is not present with kernel 2.6.32-131.21.1.el6,
> it's present with updates 2.6.32-220.4.1.el6 and 2.6.32-220.4.2.el6.
> FYI it's a CentOS6 64bit installed on a DELL Latitude E6500.
> I tried with another laptop (DELL D810) with an up-to-date CentOS6
> (32bit) installed on it: same behaviour, the disk is not accessible w/
> latest kernel but is accessible w/ 2.6.32-131.

I was on a CentOS 5...
I tried on a 2.6.32-220.4.1.el6.x86_64 and it still works fine with my USB key...
usb 1-4: new high speed USB device using ehci_hcd and address 2
usb 1-4: New USB device found, idVendor=1b1c, idProduct=0b29
usb 1-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-4: Product: Voyager Mini
usb 1-4: Manufacturer: Corsair
usb 1-4: SerialNumber: 37b47c25e57156
usb 1-4: configuration #1 chosen from 1 choice
Initializing USB Mass Storage driver...
scsi4 : SCSI emulation for USB Mass Storage devices
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
usb-storage: device scan complete
scsi 4:0:0:0: Direct-Access     Corsair  Voyager Mini     0.00 PQ: 0 ANSI: 2
sd 4:0:0:0: Attached scsi generic sg3 type 0
sd 4:0:0:0: [sdc] 15771759 512-byte logical blocks: (8.07 GB/7.52 GiB)
sd 4:0:0:0: [sdc] Write Protect is off
sd 4:0:0:0: [sdc] Mode Sense: 00 00 00 00
sd 4:0:0:0: [sdc] Assuming drive cache: write through
sd 4:0:0:0: [sdc] Assuming drive cache: write through
 sdc: sdc1
sd 4:0:0:0: [sdc] Assuming drive cache: write through
sd 4:0:0:0: [sdc] Attached SCSI removable disk

So, apparently for you it stops just before the usbcore...
Wild guess... USB3 drive?