[CentOS] Fwd: Re: Problem installing 6.3 on HP8540w laptop

Thu Nov 15 21:47:10 UTC 2012
m.roth at 5-cent.us <m.roth at 5-cent.us>

david wrote:
<snip tale 'o' woe>
> Runlevel is N 3
> Network Status reveals three configured devices, and active are "lo eth0"
> ifcfg-eth0 is as you describe
> Performing "service network start" and "chkconfig network on" and a
> reboot did not solve the problem.  eth0 had an ipv6 address, but no
> inet addr, which means it's not going to work in my home network.
> I then added to the file /etc/sysctl.conf
>   the line: net.ipv6.conf.all.disable_ipv6 = 1
> and rebooted.
> Still no IP address, and when I issued "service network restart" I get:
>    failed:  no link present.  Check cable?
Try, as root, ethtool eth0.

> HOWEVER, pulling the ethernet cable and re-inserting it, then issuing
> "service network restart" got a valid address.   After a reboot,
> again it didn't work.  However, after waiting a while, I tried
> "network start", got some messages about a file existing, and got an
> IP address.

*That* sounds like you've got a cable/jack problem. Nearly trip over the
cable recently?