[CentOS] Fwd: Re: Problem installing 6.3 on HP8540w laptop

Thu Nov 15 21:27:59 UTC 2012
david <david at daku.org>

>On Thursday 15 November 2012 18:36:16 david wrote:
> > Folks
> >
> > Just for laughs, I tried installing Centos 6.3 on the laptop HP
> > 8540w.  Windows 7 installed earlier, but I had to import a driver for
> > the Ethernet controller since it was not supported on the
> > distribution DVD of Windows7.
> >
> > The Centos installation I chose was the "NetInstall".  The
> > installation process identified eth0, I selected IPV4 DHCP, disabled
> > IPV6, and successfully completed the install of "desktop" using the
> > wired connection through my home network.  The wireless was turned
> > off.  The ethernet controller shows up in Windows with the name "Intel
> >  8255LM".
> >
> > When the reboot occurred after installation, the Ethernet did not
> > work.  The "ifconfig eth0" command showed no IP address.  Where do I
> > go from here?
> >
> > Thanks
> >
> > David
> >
> > _______________________________________________
> > CentOS mailing list
> > CentOS at centos.org
> > http://lists.centos.org/mailman/listinfo/centos
> >
At 12:12 PM 11/15/2012, you wrote:

>From: Russell Clay1 <russclay at gmail.com>
>Organization: google
>To: CentOS mailing list <centos at centos.org>
>Subject: Re: [CentOS] Problem installing 6.3 on HP8540w laptop
>Date: Thu, 15 Nov 2012 20:07:42 +0000
>User-Agent: KMail/1.12.4 (Linux/2.6.32-71.el6.x86_64; KDE/4.3.4; x86_64; ; )
>References: <201211151837.qAFIblvY002716 at telford.daku.org>
>In-Reply-To: <201211151837.qAFIblvY002716 at telford.daku.org>
>MIME-Version: 1.0
>Content-Type: Text/Plain;
>   charset="iso-8859-1"
>Content-Transfer-Encoding: 7bit
>Message-Id: <201211152007.42137.russclay at gmail.com>
>Try checking the following:
>1. The run level is currently set for networking:
>Log in as route, and issue the command 'runlevel'.
># Default runlevel. The runlevels used are:
>#   0 - halt (Do NOT set initdefault to this)
>#   1 - Single user mode
>#   2 - Multiuser, without NFS (The same as 3, if you do not have networking)
>#   3 - Full multiuser mode
>#   4 - unused
>#   5 - X11
>#   6 - reboot (Do NOT set initdefault to this)
>2. Check the network service
>[root at aftp ~]# service network status
>Configured devices:
>lo eth0
>Currently active devices:
>lo eth0
>To turn the network on, 'service network start'.
>To make the change permanent, issue the command, 'chkconfig network on'
>Also, make sure the the eth0 device is configured properly:
>cat /etc/sysconfig/network-scripts/ifcfg-eth0

Russell, and Mark:

Here's what I get:

If I do a netinstall and select "Desktop", everything seemed to work 
out of the box.  However, I really didn't want that much software 
installed, so I tried installing "minimal".

I then get:

Runlevel is N 3
Network Status reveals three configured devices, and active are "lo eth0"

ifcfg-eth0 is as you describe

Performing "service network start" and "chkconfig network on" and a 
reboot did not solve the problem.  eth0 had an ipv6 address, but no 
inet addr, which means it's not going to work in my home network.

I then added to the file /etc/sysctl.conf
  the line: net.ipv6.conf.all.disable_ipv6 = 1
and rebooted.

Still no IP address, and when I issued "service network restart" I get:
   failed:  no link present.  Check cable?

HOWEVER, pulling the ethernet cable and re-inserting it, then issuing 
"service network restart" got a valid address.   After a reboot, 
again it didn't work.  However, after waiting a while, I tried 
"network start", got some messages about a file existing, and got an 
IP address.

This seems strange.  But, the computer is now up and accessing the 
internet for YUM updates.