[CentOS] Centos 6.2 x64 after GRUB menu, black screen with blinking cursor

Wed Oct 31 11:02:20 UTC 2012
David McGiven <davidmcgivenn at gmail.com>

Dear CentOS users,

I installed CentOS 6.2 x64 in a Sun Fire X4450 machine, it has 4 disks and
I configured them to be a single volume (no RAID). The installer sees the
volume perfectly, its 570Gb. I created two ext3 partitions, /dev/sda1 and
/dev/sda2. In the logs I see they are formated correctly. All the files are

Then when I reboot, I get to the GRUB menu. Choose the first and only
option, and immediately after that I only see a black screen with blinking
cursor on top left.

I've tried recreating the grub manually with :
find /boot/grub/stage1 (reported it on hd0,0)
root (hd0,0)
setup (hd0)

Then I try to boot and I get the same blinking cursor.

I tried another approach with no luck either :
replacing root=LABEL=UUID for root=/dev/sda1 just to see if this could help
... but I have the same problem.

I don't really now what's going on. Is there anyway to put grub into
verbose mode so I can see what exactly it is doing or looking for ?

Thanks in advance.