[CentOS] inittab - huh what's it good for?

Tue Apr 16 21:33:53 UTC 2013
Michael H. Warfield <mhw at WittsEnd.com>

On Tue, 2013-04-16 at 16:18 -0400, James B. Byrne wrote:
> We run a CentOS-5 based hylafax server with external serial modems. We
> are transitioning to an Asterisk system using IAXmodem running on
> CentOS-6.

> On the CentOS-5 system to start the fax modems we added these lines to
> inittab:

> # Add fax lines and always ALWAYS run "telinit q" after making a change.
> fax1:2345:respawn:/usr/sbin/faxgetty ttyS0
> fax2:2345:respawn:/usr/sbin/faxgetty ttyS1

> On the CentOS-6 host we did this, in accordance with the instructions
> provided in the various README files and man pages.

> # send
> IA00:2345:respawn:/usr/bin/iaxmodem ttyIAX0
> # receive
> mo00:2345:respawn:/usr/sbin/faxgetty ttyIAX0
> # send
> IA01:2345:respawn:/usr/bin/iaxmodem ttyIAX1
> # receive
> mo01:2345:respawn:/usr/sbin/faxgetty ttyIAX1

> However, when I do an init q the faxgetty instances do not start.  If
> I run faxgetty from the command line in detached mode for each of them
> (faxgetty -D ttyIAX0) then they do start.  The iaxmodem instances are
> started from an init.d script as far as I can tell.  They appear and
> disappear with service iaxmodem start and stop in any case and they
> most certainly do not respawn if the service is stopped.

> So, my question is: Does inittab have any use on el6 systems?  What is
> its replacement? In other words, how do I accomplish what I am told to
> do with respect to iaxmodem and faxgetty that formerly worked in
> inittab and now evidently does not?

What you've described above works with CenOS 5 running sysv-init.  It
doesn't work with CentOS 6 because sysv-init has been replaced by
upstart.  That, in turn, will end up being replaced by systemd when 7
eventually comes out.  About the only thing that /etc/inittab is used
for under upstart or systemd is for the initial run level.  You might
want to read up on the upstart documentation and look at the contents of
the /etc/init directory.  The /etc/init.d directory contains the
sysv-init init scripts.  The /etc/init directory (no .d) has
configuration files for upstart.  Upstart can start sysv services and
run sysv-init style init scripts as well.

> -- 
> ***          E-Mail is NOT a SECURE channel          ***
> James B. Byrne                mailto:ByrneJB at Harte-Lyne.ca
> Harte & Lyne Limited          http://www.harte-lyne.ca
> 9 Brockley Drive              vox: +1 905 561 1241
> Hamilton, Ontario             fax: +1 905 561 0757
> Canada  L8E 3C3

Michael H. Warfield (AI4NB) | (770) 985-6132 |  mhw at WittsEnd.com
   /\/\|=mhw=|\/\/          | (678) 463-0932 |  http://www.wittsend.com/mhw/
   NIC whois: MHW9          | An optimist believes we live in the best of all
 PGP Key: 0x674627FF        | possible worlds.  A pessimist is sure of it!
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 482 bytes
Desc: This is a digitally signed message part
URL: <http://lists.centos.org/pipermail/centos/attachments/20130416/fc5555a3/attachment-0005.sig>