[CentOS] inittab - huh what's it good for?

Tue Apr 16 20:18:49 UTC 2013
James B. Byrne <byrnejb at harte-lyne.ca>

We run a CentOS-5 based hylafax server with external serial modems. We
are transitioning to an Asterisk system using IAXmodem running on

On the CentOS-5 system to start the fax modems we added these lines to

# Add fax lines and always ALWAYS run "telinit q" after making a change.
fax1:2345:respawn:/usr/sbin/faxgetty ttyS0
fax2:2345:respawn:/usr/sbin/faxgetty ttyS1

On the CentOS-6 host we did this, in accordance with the instructions
provided in the various README files and man pages.

# send
IA00:2345:respawn:/usr/bin/iaxmodem ttyIAX0
# receive
mo00:2345:respawn:/usr/sbin/faxgetty ttyIAX0
# send
IA01:2345:respawn:/usr/bin/iaxmodem ttyIAX1
# receive
mo01:2345:respawn:/usr/sbin/faxgetty ttyIAX1

However, when I do an init q the faxgetty instances do not start.  If
I run faxgetty from the command line in detached mode for each of them
(faxgetty -D ttyIAX0) then they do start.  The iaxmodem instances are
started from an init.d script as far as I can tell.  They appear and
disappear with service iaxmodem start and stop in any case and they
most certainly do not respawn if the service is stopped.

So, my question is: Does inittab have any use on el6 systems?  What is
its replacement? In other words, how do I accomplish what I am told to
do with respect to iaxmodem and faxgetty that formerly worked in
inittab and now evidently does not?

***          E-Mail is NOT a SECURE channel          ***
James B. Byrne                mailto:ByrneJB at Harte-Lyne.ca
Harte & Lyne Limited          http://www.harte-lyne.ca
9 Brockley Drive              vox: +1 905 561 1241
Hamilton, Ontario             fax: +1 905 561 0757
Canada  L8E 3C3