[CentOS] Frustrated. Java on Centos 6 doesn't give an error message when downloading from a Samsung Galaxy S3

Sat Jun 1 04:52:35 UTC 2013
Rock <Rocksockdoc at gmail.com>

On Mon, 27 May 2013 16:31:01 -0400, Scott Robbins wrote:

> As I mentioned, I've only used the file browser method (and
> things were accessible) in a more recent distribution.  
> Otherwise, I've used the manual commands.
> Sorry I can't be of more help here.

Hi Scott,
You've been a GREAT help, as have the others!
I'm back to working with the original libmtp, with VLC 
working just fine (but I'm not sure how to test rhythmbox
as I've never used it).

I'm confused how to explain the idealized setup since it 
took a few reboots and gyrations to get it to work again 
for me once I reinstalled the original Centos libmtp, 
and especially because we (apparently) have to plug the phone 
in to see the MTP/PTP setup screen, and once we do that, 
we again have to reboot, so, this sequence below is idealized 
as I went through a bunch of reboots in the process, and I 
forgot to unlock the phone a couple of times also.
With that caution as the caveat, I "think" the simplest 
procedure for connecting by wire on Centos 6 is the following:

0. DO THIS ONCE! Connect the Samsung Galaxy S3 Android 4.0.4 
phone by USB cable to your Centos 6 PC in order to put the
phone permanently into PTP mode (as explained earlier)
and then (I think) you MUST disconnect the phone and reboot 
the Centos PC!

1. With Centos booted, no phone connected, and the phone already 
in PTP mode, make sure the phone is unlocked! <== very important step!

2. With the phone unlocked, connect it by USB cable to the Centos PC.

3. The phone will beep, and your "Places" menu should have 
"SAMSUNG_Android_SGH-T999" and your file browser should open 
up to location "gphoto2://[usb:003,003]/".

At this point, you can copy and paste picture and screenshot 
files from your phone to your Centos PC!

I just tested that sequence, and, as long as both the phone 
is unlocked at the time of connection, and a reboot (or two) 
occur after the libmtp was put back to the original, it works 
as desired (for me).

Since a user new to this thread won't have touched their 
libmtp, they won't have to do all the reboots that I did.

Note: It seems to me there should be no need to install the 
new libmtp (since we're using PTP instead); hence vlc and 
rhythmbox should be unharmed; however, this sequence worked 
with both the old libmtp and the new libmtp; but, of course, 
neither rhythmbox nor vlc worked with the new libmtp, so, 
that's why I re-installed the old libmtp (and this won't 
work unless you reboot after messing with the libmtp - 
for reasons wholly unknown to me).

Whew! Sorry for all the confusion. Things are only simple
when they make sense. Thanks for all your kind support, 
patience, and help! 

I'm amazed at both how hard it is to figure out this
workaround ... yet - how easy the workaround is - once 
you know to both keep the phone in PTP mode and to ensure
it is "alive" when connected.

Note: The "real" solution is to get MTP to work, which is
the point of Ljubomir Ljubojevic's post earlier today.