[CentOS] Frustrated. Java on Centos 6 doesn't give an error message when downloading from a Samsung Galaxy S3

Sun Jun 2 00:49:52 UTC 2013
Scott Robbins <scottro at nyc.rr.com>

On Sat, Jun 01, 2013 at 11:13:58PM +0200, Ljubomir Ljubojevic wrote:

> >>
> >> Please provide link to rpm for Rock. Thanks.
> >
> > Firstly, MANY thanks--your link was the thing that fixed it for me.
> >
> > It wasn't an rpm, I just used the link that you gave
> >
> > http://marcofalchi.blogspot.com/2012/02/android-ics-usb-storage-on-fedora-16.html,
> > downloaded the tarball from the link on the page, ran .configure && make &&
> > sudo make install.
> >
> Here is link to mtfs source rpm I posted earlier, but I do not have time 
> to recompile it: 
> ftp://ftp.pbone.net/mirror/ftp.sourceforge.net/pub/sourceforge/f/fu/fuduntu/sources/mtpfs-1.1-0.3.svn20120510.fu2012.src.rpm

Just tried that but it wants the newer libmtp which may mess up vlc.   

On the system I use as workstation-cum-server (minimal server stuff) I'd
rather be sure that vlc is working. 
Also, for Rock's purposes, might not be good, because, I understand it, he
also wants vlc, so while I fully agree that it would be better to have it
from an rpm, in this case, (for me), it's more trouble than it's worth for
the machine that I'm most likely to use. 
I built it on a VM running i386 just to see how it would do.

Actually, I had less luck with it than on bare metal--part of that may be
due to it being a VM, but the phone works fine with more current
distributions on VM.

The rpms for later libmtp and mtpfs all built and installed without
problem, but though I could mount the phone, I was unable to see anything
in the directories, even after running mtp-detect.

So...my _personal_ experience with this is still rather iffy.  

Experimentation indicates that on the install where I have gotten it
working, I have to run mtp-detect 2 or 3 times, till it completes, then I
can mount the device. 

It's probably quicker (for me in my particular situation) to start up the
Lubuntu VM I have on this and mount it that way.  

Still, as of today, I'm way ahead of where I was before reading your post.

Rock, I can almost certainly make an x86_64 rpm for you, but it would
probably require that later libmtp which might cause its own issues.

Scott Robbins
PGP keyID EB3467D6
( 1B48 077D 66F6 9DB0 FDC2 A409 FA54 EB34 67D6 )
gpg --keyserver pgp.mit.edu --recv-keys EB3467D6