[CentOS] lost connection during yum update

Sun Mar 10 12:52:50 UTC 2013
Scot P. Floess <sfloess at nc.rr.com>

For whatever it's worth - I yum update'd two VMs without any trouble 
whatsoever (from 6.3 to 6.4) and am in the process of updating a laptop...
Not that it should matter but they are both guests running on a CentOS 5.9 
Xen host.

I'm in the process of updating a laptop - I'm hoping it works too...

On Sun, 10 Mar 2013, Frank Cox wrote:

> Well, this is interesting.  I have three systems, all of which now have the
> same problem.
> I was running "yum update" on these machines via a vnc connection (running a
> vnc desktop on one of them, and logging into the others with a a
> gnome-terminal on my vnc desktop), when my vnc desktop suddenly "went away" for
> some reason.  And that killed the "yum update" jobs on the computers.
> Subsequent to that, I logged back into the machines and ran yum update again. It
> told me to run yum-complete-transaction.  When I ran yum-complete-transaction I
> got screen after screen of "x is a duplicate with x" where x consists of a huge
> list of packages.
> I then ran "package-cleanup --cleandupes" and then ran "yum update" again and
> all appeared to be well.  "yum update" completed without error and I thought I
> was home free.
> I then rebooted the machines and found out that I'm still out of luck.  After
> the initial grub screen I get this:
> Kernel panic - not syncing: VFS: unable to mount root fs on unknown-block(0,0)
> PID: 1,comm: swapper not tainted 2.6.32-358.0.1.el6.i686 #1
> Call trace
> Followed by a series of numbers that I can post if they're needed.
> I booted one of these machines off of a Centos 6.4 "minimal" CD and ran the
> rescue mode.  It mounted the drive under /mnt/sysimage with no problem.  I
> can see everything on it that I expect to see.
> I then booted the CD again and tried running the "upgrade an existing system"
> option, and told it to reinstall the bootloader.  That's about all that it
> appeared to do: "Installing bootloader", then it told me to reboot. Which I did.
> And I got the same kernel panic again that I just posted above.
> What has gone wrong here and how can I fix it?   All of the data seems to be on
> the drive just like it should be, but it won't boot up.
> Again, I have three systems that appear to have exactly the same problem.
> -- 
> MELVILLE THEATRE ~ Real D 3D Digital Cinema ~ www.melvilletheatre.com
> www.creekfm.com - FIFTY THOUSAND WATTS of POW WOW POWER!
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

Scot P. Floess             RHCT  (Certificate Number 605010084735240)
Chief Architect FlossWare  http://sourceforge.net/projects/flossware