[CentOS] Frustrated. Java on Centos 6 doesn't give an error message when downloading from a Samsung Galaxy S3

Fri May 31 20:50:00 UTC 2013
Rock <Rocksockdoc at gmail.com>

On Fri, 31 May 2013 11:50:03 -0700, John R Pierce wrote:

> leave it in the mode you want the USB 
> connection to operate in.

Thanks. I'll leave the Android 4.0.4 phone in PTP mode then.

In order to be thorough, I wanted to write up a summary to
help others; so, to see if it was the updated libmtp that 
made the difference, I ran the following:

$ sudo yum remove libmtp (this removed the updated libmtp)
$ sudo yum install rhythmbox (this installed the old libmtp)
                          (& replaced the missing rhythmbox)
$ sudo yum --enablerepo rpmforge install vlc (this replaced VLC)

Then, I plugged in the Samsung Galaxy S3 by USB cable
(with the media mode set to PTP camera mode).

Nothing happened.

Lesson learned: The solution requires more steps, which may be
(at the very least)
a) Update libmtp on Centos
b) Switch the Android 4.0.4 phone from MTP to PTP (camera mode).
c) ? unknown other steps ?

Luckily, I documented all the steps performed in the past few
weeks so I simply repeated the successful ones.

Namely, I removed the old libmtp again (see previous posts in this 
thread for details) and re-installed the new libmtp, but, nothing 
showed up when I plugged in the phone by USB cable.

Hmmm... So I rebooted the Centos laptop to see if that made a

OK, I rebooted, and PTP mode is working again. 

So, this seems to be the sequence for the next person to 
follow in our footsteps on Centos 6 with an Android 4.0.4 phone:
1. Remove the original libmtp
NOTE: This will remove rhythmbox and vlc & any other program 
      with dependencies on libmtp)
2. Update libmtp with Scott's libmtp
3. Reboot the Centos6 PC <== this is an important step!
4. Switch the Android 4.x phone from MTP to PTP mode (if not already)
5. Connect the Android phone by USB cable 

The one problem I'm having now is that I can't re-install 
rhythmbox & vlc.

This failed after the newer libmtp was installed:
$ sudo yum install rhymthbox
==> Error: Package: rhythmbox-0.12.8-1.el6.x86_64 (base)
==> Requires: libmtp.so.8()(64bit)
==> Available: libmtp-1.0.1-2.el6.x86_64 (base) libmtp.so.8()(64bit)
==> Installed: libmtp-1.1.6-0.el6.x86_64 (installed) Not found
==> You could try using --skip-broken to work around the problem
==> You could try running: rpm -Va --nofiles --nodigest

Not knowing how to proceed, I vainly tried the suggested 
"--skip-broken" option, but it simply skipped the install 
sudo yum install rhythmbox --skip-broken
==> Processing Dependency: libmtp.so.8()
==> (64bit) for package: rhythmbox-0.12.8-1.el6.x86_64
==> Packages skipped because of dependency problems: 
==> rhythmbox-0.12.8-1.el6.x86_64 from base

So, I guess the question is:
Q: How do I install rhythmbox & vlc with the newer libmtp?