[CentOS] Frustrated. Java on Centos 6 doesn't give an error message when downloading from a Samsung Galaxy S3

Fri May 31 22:24:21 UTC 2013
Ljubomir Ljubojevic <centos at plnet.rs>

On 05/31/2013 10:50 PM, Rock wrote:
> On Fri, 31 May 2013 11:50:03 -0700, John R Pierce wrote:
>> leave it in the mode you want the USB
>> connection to operate in.
> Thanks. I'll leave the Android 4.0.4 phone in PTP mode then.
> So, this seems to be the sequence for the next person to
> follow in our footsteps on Centos 6 with an Android 4.0.4 phone:
> 1. Remove the original libmtp
> NOTE: This will remove rhythmbox and vlc & any other program
>        with dependencies on libmtp)
> 2. Update libmtp with Scott's libmtp
> 3. Reboot the Centos6 PC <== this is an important step!
> 4. Switch the Android 4.x phone from MTP to PTP mode (if not already)
> 5. Connect the Android phone by USB cable
> The one problem I'm having now is that I can't re-install
> rhythmbox & vlc.
> This failed after the newer libmtp was installed:
> $ sudo yum install rhymthbox
> ==> Error: Package: rhythmbox-0.12.8-1.el6.x86_64 (base)
> ==> Requires: libmtp.so.8()(64bit)
> ==> Available: libmtp-1.0.1-2.el6.x86_64 (base) libmtp.so.8()(64bit)
> ==> Installed: libmtp-1.1.6-0.el6.x86_64 (installed) Not found
> ==> You could try using --skip-broken to work around the problem
> ==> You could try running: rpm -Va --nofiles --nodigest
> Not knowing how to proceed, I vainly tried the suggested
> "--skip-broken" option, but it simply skipped the install
> altogether:
> sudo yum install rhythmbox --skip-broken
> ==> Processing Dependency: libmtp.so.8()
> ==> (64bit) for package: rhythmbox-0.12.8-1.el6.x86_64
> ==> Packages skipped because of dependency problems:
> ==> rhythmbox-0.12.8-1.el6.x86_64 from base
> So, I guess the question is:
> Q: How do I install rhythmbox & vlc with the newer libmtp?
That is best solved by asking Red Hat (opening a bug) to update libmtp 
and rhythmbox packages. If they accept, then vlc will be recompiled by 
all third-party repositories, and problem solved for all RHEL/CentOS/SL 

If not, one or all the third-party repositories will have to create 
libmtp, rhythmbox and vlc packages, but in a repository that can 
override base packages (so not EPEL).

So, can someone from this list and Red Hat subscription open a bug 
report using Rock's last e-mail (one I responded to)?

Ljubomir Ljubojevic
(Love is in the Air)
PL Computers
Serbia, Europe

StarOS, Mikrotik and CentOS/RHEL/Linux consultant