[CentOS] password problems new centos 6.4 install and sl63 install. [SOLVED?]

Wed Feb 12 08:34:54 UTC 2014
g <geleem at bellsouth.net>

well, yes. but why?

On 02/12/2014 03:46 AM, g wrote:
> greetings,
> a previous install and updated centos 6.4 from dvd 1 x86_64 got
> trashed. not sure of cause. no big deal. install practice never
> hurts. :-)
> now, installation is:
> CentOS-6.4-x86_64-bin-DVD1.iso installed as;
> CentOS (2.6.32-358.el6.x86_64) - root (hd1,2)
> SL-63-i386-2012-08-24-LiveCD.iso installed and updated as;
> Scientific Linux (2.6.32-431.1.2.el6.i686) - root (hd1,5)
> /dev/sdb5    /home
> after initial install of c6.4, second install phase went well.
> rebooted and checked boot up 3 times, all with successful logins.
> needed some kde configuration information from sl63, rebooted,
> selected sl63, boot ok. when tried to login to kde, user 'geo'
> password refused and user 'root' password refused.
> booted sl-62-i386 install dvd in rescue mode;
>     chroot /mnt/sysimage
>     passwd root
>     passwd geo
>     exit
>     exit
>     reboot
> login to sl63 as 'geo' and 'root' ok.
> ran email, ran some web work.
> rebooted to centos, 'geo' and 'root' passwords refused, tried twice,
> booted centos dvd-1  in rescue mode, made same entries as with sl62.
> rebooted to c64, login to c64 as 'geo' and 'root' ok.
> rebooted to sl62, tried to login as 'geo' and 'root', nfw, refused.
> it is now a continuous cycle of repeating of above.
> any and all help, ideas, suggestions, will be greatly appreciated.
> tia.

after running searches with near exact, then various wordings
of problem against sites; centos.org, fnal.gov, and,
fedoraproject.org and with no domain named, nothing hit that
was close.

after thinking about what was happening and how the 2 systems
where set up, the only things that was common between them was
both used same /home partition. both systems had the other system
mounted in /hdd/sd/xx.

'SWAG' time.

i could think of nothing to try other than to comment out the
mounting of the other system in the 2 fstab files.

booted centos install dvd to rescue mode, ran the 'game' again.

booted up sl63, logins ok.

booted up c64, logins ok.

'DANK' time.

anyone care to make a suggestion as to why unmounting other system
cured problem?

with previous installs of different distributions and with mounting
non booted systems to mounted system, i have not had problem.


peace out.

in a world with out fences, who needs gates.