[CentOS] dovecot move doesn't work

Wed Jan 7 22:01:03 UTC 2015
Peter <peter at pajamian.dhs.org>

On 01/08/2015 05:39 AM, Chuck Campbell wrote:
> I tried this using yum install dovecot22, but I get a lot of these:
> file xxx from install of dovecot22-1:2.2.15-1.gf.el6.x86_64 conflicts with file
> from package dovecot-1:2.0.9-8.el6_6.4.x86_64
> I tried yum update dovecot22, but I get:
> Package(s) dovecot22 available, but not installed.
> What is the right way to do this?

yum shell
remove dovecot
install dovecot22

I should warn you that there are subtle changes to dovecot config
between 2.0 and 2.2 that may give you issues when switching.  You will
likely have to tweak a few config options to get it to work the way you

If you're using MailDir storage then you can simply move the messages
yourself, it's as easy as using the mv command to move them from one
directory to another and you won't need the doveadm move command.

If you have any more questions feel free to ask them here or in
#ghettoforge on FreeNode IRC.