[CentOS] dovecot move doesn't work

Wed Jan 7 17:22:19 UTC 2015
Chuck Campbell <campbell at accelinc.com>

On 1/7/2015 10:52 AM, Johnny Hughes wrote:
> On 01/07/2015 10:39 AM, Chuck Campbell wrote:
>> On 1/7/2015 9:46 AM, Chuck Campbell wrote:
>>> On 1/7/2015 12:06 AM, Alexander Dalloz wrote:
>>>> Am 06.01.2015 um 23:55 schrieb Chuck Campbell:
>>>>> I'm running centos 6.6 with the default 2.0.9-xxx dovecot.
>>>>> I run sa-learn against my spam_to_learn folder, then I wan to move those emails
>>>>> to a learned_spam folder.
>>>>> when I do a doveadm -Dv move -u user learned_spam mailbox 'spam_to_learn' ALL
>>>>> I get this result:
>>>>> usage: doveadm [-Dv] [-f <formatter>] <command> [<args>]
>>>> [ ... ]
>>>>> this doesn't even list a move command, yet the dovecot pages show it and give
>>>>> examples.
>>>> The dovecot version provided by CentOS 6 simply does not have that 
>>>> feature implemented. The wiki.dovecot.org documentation reflects the 
>>>> current stable upstream status of things.
>>>>> any suggestions?
>>>> You may use the dovecot22 package provided by the ghettoforge plus 
>>>> repository, providing dovecot release 2.2.15.
>> I tried this using yum install dovecot22, but I get a lot of these:
>> file xxx from install of dovecot22-1:2.2.15-1.gf.el6.x86_64 conflicts with file
>> from package dovecot-1:2.0.9-8.el6_6.4.x86_64
>> I tried yum update dovecot22, but I get:
>> Package(s) dovecot22 available, but not installed.
>> What is the right way to do this?
> My suggestion would be to contact the ghettoforge people as this is no
> longer really a CentOS issue.  Certainly this list can be used if they
> are on it.
I'm not sure, I'll await a response from them. I do believe the Centos list
might have someone who went down this path, or a similar one, with a different
package though, that is why I am asking.
> But instead of using a repo I have personally never heard of, I would
> instead look at the documentation for version of dovecot that is in
> CentOS 6.
The documentation for dovecot 2.0.9xxx in Centos 6 does not indicate the
functionality exists. Further looking shows it is in a newer version that I am
trying to implement. The dovecot version 2.2 exists in other repos as well. I am
aware of the perils of mixing repos, hence I was asking the Centos list if
anyone has been here before.
> The purpose of running CentOS is to have enterprise level server
> software .. if you instead want latest and greatest server software, I
> would recommend that you just run the latest Fedora Server.
I agree with the Centos philosophy and have happily lived without running other
distro/repo packages until now. Since I believe providing a way for users of
this server to train spamassassin with the spam they have identified, and the
false positive messages as well is within the limits of sanity, I am attempting
to get there from here (TM). I don't believe switching the entire OS to a
bleeding edge one is appropriate. I would rather attempt one bleeding edge
(dovecot 2.2x) than everything this machine provides all in one fell swoop.

I only need to understand the mechanics of installing a package with yum, which
conflicts with the package it is intended to replace. I will live with the peril
of testing this and understand it might break something else. Meanwhile the
unbroken bits will keep functioning.

I suspect I need to 'yum remove dovecot-2.0.9x', then 'yum install
dovecot22-2.2.x' to get there, but was hoping someone on the Centos list had
been there before me.


ACCEL Services, Inc.| Specialists in Gravity, Magnetics |  (713)993-0671 ph.
                    |   and Integrated Interpretation   |  (713)993-0608 fax
448 W. 19th St. #325|            Since 1992             |  (713)306-5794 cell
 Houston, TX, 77008 |          Chuck Campbell           | campbell at accelinc.com
                    |  President & Senior Geoscientist  |

     "Integration means more than having all the maps at the same scale!"