[CentOS] Timeout before trust answer with iPhone iOS 8

Mon Jul 27 16:47:14 UTC 2015
James B. Byrne <byrnejb at harte-lyne.ca>

On Sat, July 25, 2015 09:14, David McGuffey wrote:
> Until recently I've not had any problem connecting my iPhone 4s with
> iOS
> 8 to my CentOS 6.6 desktop to move pictures and videos. Problem occurs
> with my wife's new iPhone 5s.
> Now, before I can answer the "Trust This Computer" message on the
> iPhone, I get a DBus error:
> "org.freedesktop.DBus.Error.NoReply: Message did not receive a reply
> (timeout by message bus)"
> Searching this message reveals a lot of complaints by users on Ubuntu
> and a bug in a library. But this was back in 2012-2013. Couldn't find
> anything related to CentOS.
> Appears to be a timing issue...the timer expires before I can respond
> to
> the trust question on the iPhone.
> Any guidance on how to fix this? Is there a timeout setting somewhere
> down in udev, fuse, or gvfs?
> DaveM

Fix, no.  Work-around, maybe. Providing I recall this correctly.

I ran into this when I first updated to ios8 and what seemed to work
for me then was to make the connection, ignore the time-out, trust the
computer on the iPhone, and then unplug and re-plug the iPhone's USB
connection to the host. The second connection attempt worked as I

***          e-Mail is NOT a SECURE channel          ***
        Do NOT transmit sensitive data via e-Mail
James B. Byrne                mailto:ByrneJB at Harte-Lyne.ca
Harte & Lyne Limited          http://www.harte-lyne.ca
9 Brockley Drive              vox: +1 905 561 1241
Hamilton, Ontario             fax: +1 905 561 0757
Canada  L8E 3C3