[CentOS] Any alternative to Single User Mode

Mon Jun 15 01:36:40 UTC 2015
Animesh Pandey <animeshpandey.etno at gmail.com>

On Sun, Jun 14, 2015 at 9:06 PM, jd1008 <jd1008 at gmail.com> wrote:

> On 06/14/2015 06:47 PM, Animesh Pandey wrote:
>> I actually opened the Virtual Disk Image (.vdi) on http://www.vmxray.com/
>> .
>> I could see that despite my disk being of 100GB only ~65GB was being
>> shown.
>> All the stuff related ot the local user was not visible at all.
>> After I restarted my VM, the OS gets stuck here (
>> http://i.stack.imgur.com/KVYxV.png). Even after trying the single user
>> login it was stuck there. But the emergency mode worked alright.
>> On Sun, Jun 14, 2015 at 8:37 PM, jd1008 <jd1008 at gmail.com> wrote:
>>> On 06/14/2015 06:28 PM, Animesh Pandey wrote:
>>>  Hi,
>>>> I am working on Centos6.6 on a VirtualBox on Windows Host. Today I
>>>> started
>>>> to have booting issues in the OS. It won't get past the loading screen.
>>>> I
>>>> checked and found that the files related to the user "cloudera" on the
>>>> system were not accessible. Only the files related to root were
>>>> accessible.
>>>> This is why I was am not able to do a single user login but an emergency
>>>> login was possible. This is just a guess.
>>>> This all happened due to some update in the Virtual Machine that I use
>>>> to
>>>> run CentOS.
>>>> Is there any workaround for this issue?
>>>> Thanks and regards,
>>>> Animesh Pandey
>>>>  I wish you could provide more info.
>>> How can you determine that inaccessibility to a user's
>>> files will prevent centos from taking you all the way to
>>> the login (or welcome) screen?
>>> I think something else is going on and my guess is that
>>> the centos files themselves have been corruped.
>>> Can you re-install centos ?
>> Please do not top-post.
> I am having trouble following your terminology.
> Emergency model?
> On my centos installation, there is no "Emergency ...."
> to select from the list of kernels to boot.
> Also, when you say "worked alright" do you
> mean that you were able to access what you thought
> was missing?
> Can you go to full multiuser?
>>> _______________________________________________
>>> CentOS mailing list
>>> CentOS at centos.org
>>> http://lists.centos.org/mailman/listinfo/centos
>>>  _______________________________________________
>> CentOS mailing list
>> CentOS at centos.org
>> http://lists.centos.org/mailman/listinfo/centos
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

Sorry for top posting.

Let me give you a clearer idea.

1. My regular boot freezes after loading is completed.
2. I read on the internet that sometimes due to an update in VirtualBox,
this error might occur. To rectify it, I must re-install VirtualBox's Guest
Additions. For this, I require booting in a Single User Mode.
3. For that, I followed the correct steps as given here (
But still the system froze on that same point.
4. Then I read about an Emergency mode which is even lower level to that of
Single User mode. I was able to log in and see the files that I
created/modified as root. I could not see any file/folder that related the
local user "cloudera" on which I used to work. This is where I thought of
seeing the contents of the Image using vmxray.com and found that a large
part of the dick is not visible. This part contains that files related to
"cloudera". I felt as if any information related to "cloudera" user has
been lost.

I basically need to access files that I made as "cloudera" on CENTOS and if
possible re-install the Guest Additions that ma solve this issue. But for
this I need to be able to boot as a Single User.