[CentOS] explain strange behavior

Fri Aug 19 18:38:46 UTC 2016
Valeri Galtsev <galtsev at kicp.uchicago.edu>

On Fri, August 19, 2016 1:12 pm, Dan Hyatt wrote:
> In my bin directory, most of the binaries are linked to it. It is in my
> path. I have googled this and cannot find anything close.
> I am running bash on centos6.8
> When I run   "which command" most of the files in this custom bin
> directory show up.
> When I run "which file.jar" it cannot see it, but I can *ls* the file
> (soft link)

Do these files that are not shown by which command have "execute" bit on
for everyboty (in other words, can regular user executing the command
"which" execute that file, and read that file: what is set in UNIX
permissions for that file.

Showing us what

ls -l /usr/local/bin/file.jar

(if it is symlink, show us permission of actual file symlink points to)


> as which only works on executables (according to man page), I created a
> dan.jar empty file and did a which on dan.tar and found it.
> can anyone explain what is happening and how I can soft link the jar
> files to my bin directory so which can see them?
> Dan
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> https://lists.centos.org/mailman/listinfo/centos

Valeri Galtsev
Sr System Administrator
Department of Astronomy and Astrophysics
Kavli Institute for Cosmological Physics
University of Chicago
Phone: 773-702-4247