[CentOS] spec file frustration (rant)

Wed Dec 14 18:29:19 UTC 2016
Leonard den Ottolander <leonard at den.ottolander.nl>

Hello Johnny,

On Wed, 2016-12-14 at 06:58 -0600, Johnny Hughes wrote:
> So:
> git clone https://git.centos.org/summary/rpms!skopeo

Apart from the syntax error because the exclamation mark is not escaped
this leads nowhere.

So I tried:

$ git clone https://git.centos.org/git/rpms/skopeo.git

> (that just happens to be what I am working on right now)
> cd skopeo
> git branch -a (so you can see the branches .. optional)
> git checkout c7-extras

So far so good. We now got a spec file. Doing the same for bc: a spec
file and patches. Still no source.

> get_sources.sh

The name suggests this is what we need (or do we??) If only I could find
that script anywhere...

So lets dig around a bit:

skopeo]$ cat .gitignore 

bc]$ cat .gitignore 

python-rhsm]$ cat .gitignore 

I think this solves Alice's issue once the .gitignore file is fixed.

For some reason the tarballs seem to be ignored. Something I need to fix
in my git config or is it at your end?


mount -t life -o ro /dev/dna /genetic/research