[CentOS] grub2-mkconfig strange error

Fri Jan 15 19:05:56 UTC 2016
Timothy Murphy <gayleard at eircom.net>

When I run "grub2-mkconfig" on my CentOS-7.1 desktop
I get the warning (4 times)
/usr/sbin/grub2-probe: error: 
  cannot find a GRUB drive for /dev/block/8.  
  Check your device.map.

What exactly does this mean?

My device map looks perfectly normal to me:
 [root at helen ~]# cat /boot/grub2/device.map
 (hd0)      /dev/sda
 (hd1)      /dev/sdb

This makes me reluctant to boot into CentOS-7.2.

An additional, possibly related, query.
When I run grub2-mkconfig it lists various OS's it finds:
Found Windows 7 (loader) on /dev/sda1
Found CentOS Linux release 7.1.1503 (Core)  on /dev/sda12
Found Windows 7 (loader) on /dev/sdb1
Found CentOS release 6.5 (Final) on /dev/sdb5
Found CentOS release 5.6 (Final) on /dev/sdc7
Why does it not list CentOS 7.2 since it
Found linux image: /boot/vmlinuz-3.10.0-327.4.4.el7.x86_64
Found initrd image: /boot/initramfs-3.10.0-327.4.4.el7.x86_64.img

Timothy Murphy  
gayleard /at/ eircom.net
School of Mathematics, Trinity College, Dublin