[CentOS] Sound restored

Fri Nov 18 01:18:28 UTC 2016
j_post <j_post at pacbell.net>

Passing on this information in case it may be useful to others.

Some months ago I posted a message about my sound on CentOS 6.8 no longer 
working. I'd done considerable research on the net and found no useful 
information on the cause. The sound worked if I booted from a live DVD of 
CentOS 6.8, but not when I booted from the hard drive.

Recently during a system update that included a new kernel there where some 
very interesting messages from yum about the problem but no information that 
helped with a solution. Someone else recently posted a message with the same 
output from yum. None of the suggestions helped with my computer though.

Then, just on a whim, I logged in as root and the sound worked, but only if I 
logged in as root.

Long story short: Copying the files in /root/.pulse to my home .pulse directory 
solved the problem. I now have sound! I have no idea how those files in 
~/.pulse got changed. It would be interesting to know if anyone has any ideas. 
(And, no, I did not do any messing around with system configuration by any 
means, so that's not how the files got changed.)