[CentOS] Trouble setting up HP Officejet Pro 8600 printer on CentOS 7 + KDE

Fri Nov 11 08:02:47 UTC 2016
anax <anax at ayni.com>

Hi Niki
don't you need a hplip addon/plugin, which you can fetch from

There, with the wizard, you get a file hplip-3.x.x.run
which you download and run using
bash hplip-3.x.x.run

This will install the addon/plugin.


On 11/11/2016 08:49 AM, Nicolas Kovacs wrote:
> Hi,
> I just installed a CentOS 7 + KDE desktop in my office's network. So
> far, I'm quite happy with the results, though I have some trouble
> getting the printer to work. All the other machines in my office
> (server, desktops, workstation) are running Slackware64 14.1 or 14.2,
> and they can all use the printer perfectly.
> I installed hplip-gui and ran it. The printer is a network printer, it
> has a static IP in the network and can also be addressed by its hostname.
>   [kikinovak at alphamule:~] $ host hp-officejet
>   hp-officejet.microlinux.lan has address
> When I run hp-setup with the default options, the setup program "sees"
> the printer, but informs me that there is a "communication problem". I
> figure this is because the default seach method is mDNS/Bonjour. I tried
> again with the SLP option, and this time the setup procedure went OK. Or
> it seemed so, as the test page was blank.
> Now what?
> A few details about my system: SELinux, IPv6 and firewall are disabled.
> CUPS is running OK. I checked on the HP website that this printer
> requires HPLIP 3.11.10 or greater, which seems OK, since the HPLIP
> version shipping with CentOS is 3.13.something.
> Cheers,
> Niki