[CentOS] fcitx-anthy request (for Japanese users)

Wed Aug 2 13:37:06 UTC 2017
H <agents at meddatainc.com>

On 08/01/2017 09:09 PM, Scott Robbins wrote:
> On Tue, Aug 01, 2017 at 08:55:22PM -0400, H wrote:
>> Scott, I am back at this again. I am able to switch between Chinese and two western languages in terminal sessions but not in GUI applications such as LO, Thunderbird, Firefox... Only the default language works in these GUI applications.
>> What setting in fcitx might I be missing?
> Well, I'm not the expert, especially at Chinese.
> I do remember in an older version of FreeBSD, to get it to work in firefox,
> I would use
> LC_CTYPE=ja_JP.UTF-8 firefox
> from a terminal, and it would then work. I never figured out why (it worked
> with other GTK apps such as libreoffice.  Hrrm, I don't think I tried in
> Thunderbird.
> Ah, also, in my .xinitrc (I boot into text mode then run startx I have,
> above the line calling the window manager
> export LC_CTYPE=en_US.UTF-8
> Do you have fcitx-gtk2 and fcitx-gtk3 installed?
> I repeat, I'm not an expert on this, my skill is in googling and finding
> out how others got it done, then just copying that and summarizing it. :)
Thank you, tried that but no difference. I have temporarily deactivated Chinese and am just trying to switch between two western languages. Again, this works fine in a terminal session but not in any GUI program I tried, including firefox, thunderbird, geany.

I do have both fcitx-gtk2 and fcitx-gtk3 installed.

I suspect there may be some configuration setting I have missed but since there is no graphical configuration utility it's hard to figure out what might be wrong by just looking at the several configuration text files.