[CentOS] Unable to run TeamViewer 13 under Centos 7 (amd64)

Tue Dec 19 14:54:36 UTC 2017
Manish Jain <bourne.identity at hotmail.com>

On 12/19/17 19:55, Johnny Hughes wrote:
> On 12/19/2017 07:16 AM, Manish Jain wrote:
>> Hi,
>> I am writing a book about Unix (Linux / FreeBSD) and my book needs
>> documentation for TeamViewer13 running under Centos 7 (64-bit).
>> Unfortunately, running TeamViewer does not get me a GUI -- the install
>> went smoothly and teamviewerd daemon is running.
>> This happens only under Centos. Under Manjaro, the same tarball
>> (teamviewer_13.0.5494_amd64.tar.xz) gets me a nice TeamViewer window.
>> But I need documentation for Centos.
>> I have tried reinstalling via rpm (teamviewer_13.0.5693.x86_64.rpm), but
>> that does not improve things. With the teamviewer command, I just get
>> "Launching TeamViewer GUI" - but nothing actually happens after that.
>> Can anyone please help me fix the issue ?
> https://download.teamviewer.com/download/linux/teamviewer.x86_64.rpm
> That seems to be the CentOS 7 x86_64 version they say SHOULD work
> (currently version 13.0.6634-0).
> After downloading that, I did (as root):
> yum install ./teamviewer.x86_64.rpm
> It pulled in a bunch of qt5 dependencies.
> After install, I ran:
> teamviewer
> it worked fine.

Hi Johnny,

Thanks for replying.

I seem to be having a very bad day.

I uninstalled the old TV, and installed the version you indicated, but I 
get nothing at all:

/home/bourne # teamviewer

CheckCPU: SSE2 support: yes
Checking setup...
Launching TeamViewer ...
Launching TeamViewer GUI ...
/home/bourne #

I deleted ~/.config/teamviewer* and ~/.local/share/teamviewer*, but 
still no luck.

Is it possible that this has something to do with Centos 7 running as a 
vm (under VirtualBox) in my box ? (But then, Manjaro vm works fine).

Tx again.
Manish Jain