[CentOS] Unable to run TeamViewer 13 under Centos 7 (amd64)

Tue Dec 19 14:25:38 UTC 2017
Johnny Hughes <johnny at centos.org>

On 12/19/2017 07:16 AM, Manish Jain wrote:
> Hi,
> I am writing a book about Unix (Linux / FreeBSD) and my book needs 
> documentation for TeamViewer13 running under Centos 7 (64-bit).
> Unfortunately, running TeamViewer does not get me a GUI -- the install 
> went smoothly and teamviewerd daemon is running.
> This happens only under Centos. Under Manjaro, the same tarball 
> (teamviewer_13.0.5494_amd64.tar.xz) gets me a nice TeamViewer window. 
> But I need documentation for Centos.
> I have tried reinstalling via rpm (teamviewer_13.0.5693.x86_64.rpm), but 
> that does not improve things. With the teamviewer command, I just get 
> "Launching TeamViewer GUI" - but nothing actually happens after that.
> Can anyone please help me fix the issue ?


That seems to be the CentOS 7 x86_64 version they say SHOULD work
(currently version 13.0.6634-0).

After downloading that, I did (as root):

yum install ./teamviewer.x86_64.rpm

It pulled in a bunch of qt5 dependencies.

After install, I ran:


it worked fine.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: OpenPGP digital signature
URL: <http://lists.centos.org/pipermail/centos/attachments/20171219/eec43200/attachment-0004.sig>