[CentOS] Unable to edit resolv.conf

Fri Jan 13 13:31:24 UTC 2017
Scott Robbins <scottro11 at gmail.com>

On Fri, Jan 13, 2017 at 07:49:48AM -0500, TE Dukes wrote:
> Hello,
> I changed ISPs and need to update name servers in resolv.conf.
> I have tried nano, gedit, Webmin, system-config-network and it won't allow
> me to make the changes.
> I have Network Manager turned off and when I enable it , eth0 and eth1 have
> no entries.
> I enabled it, added the connections, but still no changes.
> I'm stuck

I know that in Fedora, resolv.conf is now some symlink to a NetworkManager
file (I forget where).

Try doing ls -l /etc/resolv.conf, and see if that's the case in CentOS-7 as
well. (I don't use NM, so I'm not sure what the case is with it, as the
machine I'm using had that change made, if it was needed, long ago. :) )

If it does turn out to be a symlink, copy its information, if you need it, 
then delete the file, then recreate it.

Hope this helps, but I'm not sure. It is a working solution in Fedora.

Scott Robbins
PGP keyID EB3467D6
( 1B48 077D 66F6 9DB0 FDC2 A409 FA54 EB34 67D6 )
gpg --keyserver pgp.mit.edu --recv-keys EB3467D6