[CentOS] Unable to edit resolv.conf

Fri Jan 13 15:06:03 UTC 2017
TE Dukes <tdukes at palmettoshopper.com>

-----Original Message-----
From: CentOS [mailto:centos-bounces at centos.org] On Behalf Of Scott Robbins
Sent: Friday, January 13, 2017 8:31 AM
To: CentOS mailing list
Subject: Re: [CentOS] Unable to edit resolv.conf

On Fri, Jan 13, 2017 at 07:49:48AM -0500, TE Dukes wrote:
> Hello,
> I changed ISPs and need to update name servers in resolv.conf.
> I have tried nano, gedit, Webmin, system-config-network and it won't 
> allow me to make the changes.
> I have Network Manager turned off and when I enable it , eth0 and eth1 
> have no entries.
> I enabled it, added the connections, but still no changes.
> I'm stuck

I know that in Fedora, resolv.conf is now some symlink to a NetworkManager
file (I forget where).

Try doing ls -l /etc/resolv.conf, and see if that's the case in CentOS-7 as
well. (I don't use NM, so I'm not sure what the case is with it, as the
machine I'm using had that change made, if it was needed, long ago. :) )

If it does turn out to be a symlink, copy its information, if you need it,
then delete the file, then recreate it.

Hope this helps, but I'm not sure. It is a working solution in Fedora.

Hi, thanks, it does not show it being a sym link.