[CentOS] Unable to edit resolv.conf

Fri Jan 13 13:58:43 UTC 2017
Alice Wonder <alice at domblogger.net>

On 01/13/2017 05:50 AM, Albert McCann wrote:
>> -----Original Message-----
>> From: CentOS [mailto:centos-bounces at centos.org] On Behalf Of TE Dukes
>> Sent: Friday, January 13, 2017 7:50 AM
>> To: 'CentOS mailing list' <centos at centos.org>
>> Subject: [CentOS] Unable to edit resolv.conf
>> I changed ISPs and need to update name servers in resolv.conf.
>> I have tried nano, gedit, Webmin, system-config-network and it won't allow
>> me to make the changes.
>> I have Network Manager turned off and when I enable it , eth0 and eth1
>> have no entries.
>> I enabled it, added the connections, but still no changes.
> You haven't done what I've done intentionally, flag /etc/resolv.conf
> immutable with "chattr +i /etc/resolv.conf" have you?
> I do this to keep Network Manager and other busybodies from making unwanted
> / unneeded changes.

I've tried to figure out how to get Network Manager to leave various 
configuration files alone and just gave up - resorting to cron job 
running as root every minute fixing them if they have been modified.

I wish there was better documentation on how Network Manager is 
configured because I can't figure out how to get it to behave.

My home router - the caching nameserver it uses doesn't enforce DNSSEC 
and crashes about once a week, requiring a restart. So I just don't use 
it except for my phone and tablet, and just run unbound on my local 
machines, but Network Manager keeps trying to use the nameserver 
assigned by the router DHCP (which is the router) and other than a once 
a minute cron job, can't figure out how to tell Network Manager to 
ignore the nameserver setting.