[CentOS] Unable to edit resolv.conf

Fri Jan 13 15:00:23 UTC 2017
Albert McCann <mac358 at newsguy.com>

> -----Original Message-----
> From: CentOS [mailto:centos-bounces at centos.org] On Behalf Of Alice Wonder
> Sent: Friday, January 13, 2017 8:59 AM
> To: centos at centos.org
> Subject: Re: [CentOS] Unable to edit resolv.conf
> I've tried to figure out how to get Network Manager to leave various
> configuration files alone and just gave up - resorting to cron job
> running as root every minute fixing them if they have been modified.
> My home router - the caching nameserver it uses doesn't enforce DNSSEC
> and crashes about once a week, requiring a restart. So I just don't use
> it except for my phone and tablet, and just run unbound on my local
> machines, but Network Manager keeps trying to use the nameserver
> assigned by the router DHCP (which is the router) and other than a once
> a minute cron job, can't figure out how to tell Network Manager to
> ignore the nameserver setting.

Have you tried setting PEERDNS=no in the
/etc/sysconfig/network-scripts/ifcfg-<X> script(s)?

I have an ancient note here from 5.x days with the above fix.

He who finds an old key does not require a new one.