[CentOS] Unable to edit resolv.conf

Fri Jan 13 15:08:00 UTC 2017
Alice Wonder <alice at domblogger.net>

On 01/13/2017 07:00 AM, Albert McCann wrote:
>> -----Original Message-----
>> From: CentOS [mailto:centos-bounces at centos.org] On Behalf Of Alice Wonder
>> Sent: Friday, January 13, 2017 8:59 AM
>> To: centos at centos.org
>> Subject: Re: [CentOS] Unable to edit resolv.conf
>> I've tried to figure out how to get Network Manager to leave various
>> configuration files alone and just gave up - resorting to cron job
>> running as root every minute fixing them if they have been modified.
> ...
>> My home router - the caching nameserver it uses doesn't enforce DNSSEC
>> and crashes about once a week, requiring a restart. So I just don't use
>> it except for my phone and tablet, and just run unbound on my local
>> machines, but Network Manager keeps trying to use the nameserver
>> assigned by the router DHCP (which is the router) and other than a once
>> a minute cron job, can't figure out how to tell Network Manager to
>> ignore the nameserver setting.
> Have you tried setting PEERDNS=no in the
> /etc/sysconfig/network-scripts/ifcfg-<X> script(s)?
> I have an ancient note here from 5.x days with the above fix.

That might work on my desktop but I don't think it would work on my 
laptop where it seems to create new network scripts for every wifi 
network it connects to.