[CentOS] CentOS 7 install on one RAID 1 [not-so-SOLVED]

Wed Jan 25 15:51:30 UTC 2017
m.roth at 5-cent.us <m.roth at 5-cent.us>

Let me see if I can, um, reboot this thread....

I made a RAID 1 of two raw disks, /dev/sda and /dev/sdb, *not* /dev/sdax
/dev/sdbx. Then I installed CentOS 7 on the RAID, with /boot, /, and swap
being partitions on the RAID. My problem is that grub2-install absolutely
and resolutely refuses to install on /dev/sda or /dev/sdb.

I've currently got it up in a half-assed rescue mode, and have mount -o
bind /dev, /proc/ and /sys under /mnt/sysimage, and chrooted there. That's
where I'm trying to do my grub2-install.

  1. *Is* there space for grub2 to install the bootloader under where the
mdadm starts?
        Or do I have to partition the disks (/dev/sda1 100%, ditto
/dev/sdb1, then
        create the RAID 1 with the partitions, and *then* grub2-install?
  2. I *think* that one thing that grub2-install is complaining about is
that it can't
       find /boot/grub2. I've tried doing it with
        $  grub2-install --boot-directory=/boot /dev/sda
        $  grub2-install --boot-directory=/dev/md127p1/ /dev/sda
        $  grub2-install --boot-directory=/dev/md127pw/boot /dev/sda
       and it tells me it cannot find the canonical path for the grub2
directory. Is
       there some way to specify where it should fund /boot/grub2 that
I've missed?