[CentOS] Installing support for Chinese text in Centos 7

Mon Jul 17 14:21:20 UTC 2017
H <agents at meddatainc.com>

On 07/17/2017 06:11 AM, Scott Robbins wrote:
> On Sun, Jul 16, 2017 at 11:23:08PM -0400, H wrote:
>> After leaving this along for several weeks I made another attempt at trying to get fcitx up and running on CentOS 7 and the Mate desktop. I discovered that there is a diagnostic tool, fcitx-diagnose, that provided some additional information.
>> One of the missing programs was the fcitx-configtool that lacked the GUI part and that so far I have been unable to find on the 'net. It seems that the appropriate GUI tool would be fcitx-config-gtk3 and is necessary for configuring fcitx.
>> Does anyone have fcitx-config-gtk3 up and running?
> As mentioned, I don't have it working, but it shouldn't be necessary..
>> I have to vent and say that I am very, very surprised that this tool for entering Asian text on CentOS 7 is so poorly developed, poorly documented and poorly packaged. One would have thought that the Asian market for RHEL/CentOS 7 would be of sufficient importance for all relevant programs to be available in one of the key repositories.
> It takes developers, probably unpaid, to do it as they can.
> I would guess it's RedHat, an American company, that decides what goes in
> official repositories and doesn't see a need for it.
>> I am under the impression that fcitx, considered the replacement of iBus used in CentOS 6 - and which worked flawlessly - has not been updated since 2013. Further, the developers have not bothered with a proper support website, instead most information is absent.
> It seems to be. I first tried it when I had to write a script to get ibus
> to switch between English and Japanese.
> Seriously, I would file a RHEL bug report as RFA (Request for enhancement).
> Now that I mention that, I may file a request to create a package for
> fcitx-anthy.
Unfortunately I do not have a RHEL license, only using CentOS, but it would be great if you could file the RFA.

In the meantime, we should look at compiling fcitx-config-gtk3. Unfortunately, my skills in this are are very rudimentary...