[CentOS] Installing support for Chinese text in Centos 7

Tue Jul 18 13:17:17 UTC 2017
Jonathan Billings <billings at negate.org>

On Sun, Jul 16, 2017 at 11:23:08PM -0400, H wrote:
> After leaving this along for several weeks I made another attempt at
> trying to get fcitx up and running on CentOS 7 and the Mate
> desktop. I discovered that there is a diagnostic tool,
> fcitx-diagnose, that provided some additional information. 
> One of the missing programs was the fcitx-configtool that lacked the
> GUI part and that so far I have been unable to find on the 'net. It
> seems that the appropriate GUI tool would be fcitx-config-gtk3 and
> is necessary for configuring fcitx. 
> Does anyone have fcitx-config-gtk3 up and running?
> I have to vent and say that I am very, very surprised that this tool
> for entering Asian text on CentOS 7 is so poorly developed, poorly
> documented and poorly packaged. One would have thought that the
> Asian market for RHEL/CentOS 7 would be of sufficient importance for
> all relevant programs to be available in one of the key
> repositories. 
> I am under the impression that fcitx, considered the replacement of
> iBus used in CentOS 6 - and which worked flawlessly - has not been
> updated since 2013. Further, the developers have not bothered with a
> proper support website, instead most information is absent. 

My only suggestion is to try to set this up under the GNOME3 desktop
provided by CentOS, rather than what is built out of EPEL.  It's the
only desktop that has had testing by Red Hat.  MATE is provided by
EPEL as a volunteer effort, and isn't considered part of CentOS.

I encountered the same problem when I was running Cinnamon as my
desktop, I was able to add several Chinese input methods but I
couldn't actually use them.  I switched to Gnome 3 and it just worked
out of the box.

Jonathan Billings <billings at negate.org>