[CentOS] AMD Ryzen and CentOS

Thu Jun 29 21:28:47 UTC 2017
James A. Peltier <jpeltier at sfu.ca>

The issue is likely about the chipset not being properly supported and so you will have to wait and see if 6.10/7.4 helps.  You may want to check the RH release notes for RHEL 6.10/7.4 and see if support for the processor is listed there.

While I can't assure you that upgrading to 7 will fix the problem, the likeliness that will work is at least 50% better being as 7 is based on a newer kernel.

----- On 29 Jun, 2017, at 13:53, Yves Bellefeuille yan at storm.ca wrote:

| I have a new system with an AMD Ryzen 1600 CPU and I'm trying to run
| CentOS, so far without success. The only information I could find was
| a post reporting that CentOS 7 would crash during installation on a
| Ryzen system: https://www.centos.org/forums/viewtopic.php?t=61831 .
| I tried updating to the latest elrepo "mainline stable" kernel,
| version 4.11 (by booting from a live CD and using chroot to enter
| CentOS: that worked), but the system still doesn't work properly.
| I'm using CentOS 6 but I'll switch to CentOS 7 if that will help. (But
| I assume that if installing the latest kernel didn't help, neither
| would going to CentOS 7.)
| Any suggestions? Is it known whether the next version will work
| properly with Ryzen?
| Yves Bellefeuille
| <yan at storm.ca>
| _______________________________________________
| CentOS mailing list
| CentOS at centos.org
| https://lists.centos.org/mailman/listinfo/centos

James A. Peltier
IT Services - Research Computing Group
Simon Fraser University - Burnaby Campus
Phone   : 604-365-6432
Fax     : 778-782-3045
E-Mail  : jpeltier at sfu.ca
Website : http://www.sfu.ca/itservices
Twitter : @sfu_rcg
Powering Engagement Through Technology